




<!DOCTYPE html>
<!--[if IE 7 ]>    <html lang="en" class="release-page no-js ie7" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8 ]>    <html lang="en" class="release-page no-js ie8" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9 ]>    <html lang="en" class="release-page no-js ie9" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--><html lang="en" class="release-page no-js" prefix="og: http://ogp.me/ns#"><!--<![endif]-->

<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<title>Quaker Men's Lacrosse Posted 9-8 Season -  Guilford</title>



    
    
	<link rel="canonical" href="http://www.guilfordquakers.com/sports/mlax/2017-18/releases/20180702q90rsp" />
    <meta property="fb:app_id" content="280467664480" />
    
    
          <meta property="og:title"  content="Quaker Men's Lacrosse Posted 9-8 Season"  />
      <meta property="og:description"  content="Quaker Men's Lacrosse Posted 9-8 Season"  />
              <meta property="og:image" content="http://www.guilfordquakers.com/sports/mlax/2016-17/photos/0009/Styles-_Parker_-18_thumb.jpg?max_width=600&max_height=600" />
        <meta property="og:image:secure_url" content="https://www.guilfordquakers.com/sports/mlax/2016-17/photos/0009/Styles-_Parker_-18_thumb.jpg?max_width=600&max_height=600" />
        <meta property="og:image:width" content="600" />
        <meta property="og:image:height" content="600" />
          
    <meta property="og:site_name" content="Guilford" />
    <meta property="og:url" content="http://www.guilfordquakers.com/sports/mlax/2017-18/releases/20180702q90rsp" />

           <meta property="og:type" content="article" />
              <meta property="article:published_time" content="2018-07-02" />
      
    

 

<script src="https://cdn.prestosports.com/action/cdn/info/jquery.js"></script>
<script src="https://cdn.prestosports.com/action/cdn/info/modernizr.js"></script>

<link rel="stylesheet" href="/info/boilerplate.css" type="text/css" />
<link rel="stylesheet" href="/css/styles.css" type="text/css" />

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
googletag.cmd.push(function() {
    
    var adhesionMapping = googletag.sizeMapping().
            addSize([0, 0], []).
            addSize([1000, 200], [970, 66]).
            addSize([768, 200], [728, 90]).
            addSize([320, 100], [320, 50]).
            build();
    
    googletag.defineSlot('/21708449227/GUILF', [728, 90], 'gpt-ad-adhesion').
        defineSizeMapping(adhesionMapping).
        setCollapseEmptyDiv(true).
        addService(googletag.pubads()).
        setTargeting('pos', 'top');
        
        
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
});
</script>

<!-- rum header -->

<script type="text/javascript">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</script>

</head>

<body>

<div id="page">

<header id="site-header" class="site-header clearfix">

<h1 class="header-logo"><a  href="/">Guilford</a></h1>
<a class="header-text" href="/">Guilford</a>

<div id="mobile-menu-bar" class="mobile-menu-bar clearfix">
<ul class="clearfix">
<li><a href="/composite"><i aria-hidden="true" class="icon-calendar"></i> <span class="text">Composite</span></a></li>
<li><a href="#" id="search-trigger"><i aria-hidden="true" class="icon-search"></i> <span class="text">Search</span></a></li>
<li><a href="#" id="jump-to-nav"><i aria-hidden="true" class="icon-menu"></i> <span class="text">Menu</span></a></li>
</ul>
</div>

<form id="search-bar" class="search-bar" method="get" action="/search">
  <input type="text" class="text-box" name="query" value="Search" onfocus="if(this.value == 'Search') this.value = ''" onblur="if(this.value == '') this.value = 'Search'" />
  <button class="submit"><i class="icon-search"></i><span>Search</span></button>
</form>

<script>
$(function() {
  $('#search-trigger').click(function(e) {
    e.preventDefault();
    $(this).toggleClass('active');
    $('#search-bar').toggleClass('active');
  });
});
</script>

</header>










<nav id="nav" class="dropnav" role="navigation" aria-label="Main menu" data-module="dropnav">
<h1 class="offscreen">Site Navigation</h1>
<ul class="clearfix" role="menubar">
      
           
    <li class="nav nav1 has-submenu" data-follow-link="false">
      <a href="/navbar-sports-dropdown" class="nav-link" >Teams</a>
      <div id="submenu1" class="submenu level1 clearfix">

                                    




<ul class="clearfix">
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/navbar-men-dropdown"  aria-label="Teams: Men's Sports">Men's Sports</a>
      <div class="submenu level2 clearfix">
      
                                    




<ul class="clearfix">
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/bsb/navbar-dropdown"  aria-label="Teams: Men's Sports: Baseball">Baseball</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/bsb/index"  aria-label="Teams: Men's Sports: Baseball: Baseball">Baseball</a></li>
  
  
    	
      <li><a href="/sports/bsb/2017-18/roster"  aria-label="Teams: Men's Sports: Baseball: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/bsb/2017-18/schedule"  aria-label="Teams: Men's Sports: Baseball: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/bsb/2017-18/teams"  aria-label="Teams: Men's Sports: Baseball: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/mbkb/navbar-dropdown"  aria-label="Teams: Men's Sports: Basketball">Basketball</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/mbkb/index"  aria-label="Teams: Men's Sports: Basketball: Basketball">Basketball</a></li>
  
  
    	
      <li><a href="/sports/mbkb/2017-18/roster"  aria-label="Teams: Men's Sports: Basketball: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/mbkb/2017-18/schedule"  aria-label="Teams: Men's Sports: Basketball: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/mbkb/2017-18/teams"  aria-label="Teams: Men's Sports: Basketball: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/mxc/navbar-dropdown"  aria-label="Teams: Men's Sports: Cross Country">Cross Country</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/mxc/index"  aria-label="Teams: Men's Sports: Cross Country: Cross Country">Cross Country</a></li>
  
  
    	
      <li><a href="/sports/mxc/2017-18/roster"  aria-label="Teams: Men's Sports: Cross Country: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/mxc/2017-18/schedule"  aria-label="Teams: Men's Sports: Cross Country: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/mxc/2017-18/files/Guilford_MXC_results_2017.pdf"  aria-label="Teams: Men's Sports: Cross Country: Results">Results</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/fball/navbar-dropdown"  aria-label="Teams: Men's Sports: Football">Football</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/fball/index"  aria-label="Teams: Men's Sports: Football: Football">Football</a></li>
  
  
    	
      <li><a href="/sports/fball/2017-18/roster"  aria-label="Teams: Men's Sports: Football: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/fball/2018-19/schedule"  aria-label="Teams: Men's Sports: Football: 2018 Schedule">2018 Schedule</a></li>
  
  
    	
      <li><a href="/sports/fball/2017-18/teams"  aria-label="Teams: Men's Sports: Football: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/mgolf/navbar-dropdown"  aria-label="Teams: Men's Sports: Golf">Golf</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/mgolf/index"  aria-label="Teams: Men's Sports: Golf: Golf">Golf</a></li>
  
  
    	
      <li><a href="/sports/mgolf/2017-18/roster"  aria-label="Teams: Men's Sports: Golf: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/mgolf/2017-18/schedule"  aria-label="Teams: Men's Sports: Golf: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/mgolf/2017-18/files/17-18_Stats.pdf"  aria-label="Teams: Men's Sports: Golf: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/mlax/navbar-dropdown"  aria-label="Teams: Men's Sports: Lacrosse">Lacrosse</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/mlax/index"  aria-label="Teams: Men's Sports: Lacrosse: Lacrosse">Lacrosse</a></li>
  
  
    	
      <li><a href="/sports/mlax/2017-18/roster"  aria-label="Teams: Men's Sports: Lacrosse: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/mlax/2017-18/schedule"  aria-label="Teams: Men's Sports: Lacrosse: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/mlax/2017-18/teams"  aria-label="Teams: Men's Sports: Lacrosse: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/msoc/navbar-dropdown"  aria-label="Teams: Men's Sports: Soccer">Soccer</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/msoc/index"  aria-label="Teams: Men's Sports: Soccer: Soccer">Soccer</a></li>
  
  
    	
      <li><a href="/sports/msoc/2017-18/roster"  aria-label="Teams: Men's Sports: Soccer: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/msoc/2018-19/schedule"  aria-label="Teams: Men's Sports: Soccer: 2018 Schedule">2018 Schedule</a></li>
  
  
    	
      <li><a href="/sports/msoc/2017-18/teams"  aria-label="Teams: Men's Sports: Soccer: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/mten/navbar-dropdown"  aria-label="Teams: Men's Sports: Tennis">Tennis</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/mten/index"  aria-label="Teams: Men's Sports: Tennis: Tennis">Tennis</a></li>
  
  
    	
      <li><a href="/sports/mten/2017-18/roster"  aria-label="Teams: Men's Sports: Tennis: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/mten/2017-18/schedule"  aria-label="Teams: Men's Sports: Tennis: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/mten/2017-18/files/teamstat.htm"  aria-label="Teams: Men's Sports: Tennis: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/mtrack/navbar-dropdown"  aria-label="Teams: Men's Sports: Track &amp; Field">Track &amp; Field</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/mtrack/index"  aria-label="Teams: Men's Sports: Track &amp; Field: Track &amp; Field">Track &amp; Field</a></li>
  
  
    	
      <li><a href="/sports/mtrack/2017-18/roster"  aria-label="Teams: Men's Sports: Track &amp; Field: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/mtrack/2017-18/schedule"  aria-label="Teams: Men's Sports: Track &amp; Field: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/mtrack/2017-18/Marks"  aria-label="Teams: Men's Sports: Track &amp; Field: Marks">Marks</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/navbar-women-dropdown"  aria-label="Teams: Women's Sports">Women's Sports</a>
      <div class="submenu level2 clearfix">
      
                                    




<ul class="clearfix">
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wbkb/navbar-dropdown"  aria-label="Teams: Women's Sports: Basketball">Basketball</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wbkb/index"  aria-label="Teams: Women's Sports: Basketball: Basketball">Basketball</a></li>
  
  
    	
      <li><a href="/sports/wbkb/2017-18/roster"  aria-label="Teams: Women's Sports: Basketball: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wbkb/2017-18/schedule"  aria-label="Teams: Women's Sports: Basketball: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wbkb/2017-18/teams"  aria-label="Teams: Women's Sports: Basketball: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wxc/navbar-dropdown"  aria-label="Teams: Women's Sports: Cross Country">Cross Country</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wxc/index"  aria-label="Teams: Women's Sports: Cross Country: Cross Country">Cross Country</a></li>
  
  
    	
      <li><a href="/sports/wxc/2017-18/roster"  aria-label="Teams: Women's Sports: Cross Country: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wxc/2017-18/schedule"  aria-label="Teams: Women's Sports: Cross Country: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wxc/2017-18/files/WXC_results_2017.pdf"  aria-label="Teams: Women's Sports: Cross Country: Results">Results</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wlax/navbar-dropdown"  aria-label="Teams: Women's Sports: Lacrosse">Lacrosse</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wlax/index"  aria-label="Teams: Women's Sports: Lacrosse: Lacrosse">Lacrosse</a></li>
  
  
    	
      <li><a href="/sports/wlax/2017-18/roster"  aria-label="Teams: Women's Sports: Lacrosse: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wlax/2017-18/schedule"  aria-label="Teams: Women's Sports: Lacrosse: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wlax/2017-18/teams"  aria-label="Teams: Women's Sports: Lacrosse: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wsoc/navbar-dropdown"  aria-label="Teams: Women's Sports: Soccer">Soccer</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wsoc/index"  aria-label="Teams: Women's Sports: Soccer: Soccer">Soccer</a></li>
  
  
    	
      <li><a href="/sports/wsoc/2017-18/roster"  aria-label="Teams: Women's Sports: Soccer: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wsoc/2018-19/schedule"  aria-label="Teams: Women's Sports: Soccer: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wsoc/2017-18/teams"  aria-label="Teams: Women's Sports: Soccer: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/sball/navbar-dropdown"  aria-label="Teams: Women's Sports: Softball">Softball</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/sball/index"  aria-label="Teams: Women's Sports: Softball: Softball">Softball</a></li>
  
  
    	
      <li><a href="/sports/sball/2017-18/roster"  aria-label="Teams: Women's Sports: Softball: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/sball/2017-18/schedule"  aria-label="Teams: Women's Sports: Softball: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/sball/2017-18/teams"  aria-label="Teams: Women's Sports: Softball: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wswim/navbar-dropdown"  aria-label="Teams: Women's Sports: Swimming">Swimming</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wswim/index"  aria-label="Teams: Women's Sports: Swimming: Swimming">Swimming</a></li>
  
  
    	
      <li><a href="/sports/wswim/2017-18/roster"  aria-label="Teams: Women's Sports: Swimming: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wswim/2017-18/schedule"  aria-label="Teams: Women's Sports: Swimming: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wswim/2016-17/files/TopTimes"  aria-label="Teams: Women's Sports: Swimming: Times">Times</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wten/navbar-dropdown"  aria-label="Teams: Women's Sports: Tennis">Tennis</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wten/index"  aria-label="Teams: Women's Sports: Tennis: Tennis">Tennis</a></li>
  
  
    	
      <li><a href="/sports/wten/2017-18/roster"  aria-label="Teams: Women's Sports: Tennis: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wten/2017-18/schedule"  aria-label="Teams: Women's Sports: Tennis: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wten/2017-18/files/teamstat.htm"  aria-label="Teams: Women's Sports: Tennis: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wtrack/navbar-dropdown"  aria-label="Teams: Women's Sports: Track &amp; Field">Track &amp; Field</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wtrack/index"  aria-label="Teams: Women's Sports: Track &amp; Field: Track &amp; Field">Track &amp; Field</a></li>
  
  
    	
      <li><a href="/sports/wtrack/2017-18/roster"  aria-label="Teams: Women's Sports: Track &amp; Field: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wtrack/2017-18/schedule"  aria-label="Teams: Women's Sports: Track &amp; Field: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wtrack/2017-18/Marks"  aria-label="Teams: Women's Sports: Track &amp; Field: Marks">Marks</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  
    	
            
    <li class="has-submenu" data-follow-link="false">
      <a href="/sports/wvball/navbar-dropdown"  aria-label="Teams: Women's Sports: Volleyball">Volleyball</a>
      <div class="submenu level3 clearfix">
      
                                    




<ul class="clearfix">
    	
      <li><a href="/sports/wvball/index"  aria-label="Teams: Women's Sports: Volleyball: Volleyball">Volleyball</a></li>
  
  
    	
      <li><a href="/sports/wvball/2017-18/roster"  aria-label="Teams: Women's Sports: Volleyball: Roster">Roster</a></li>
  
  
    	
      <li><a href="/sports/wvball/2017-18/schedule"  aria-label="Teams: Women's Sports: Volleyball: Schedule">Schedule</a></li>
  
  
    	
      <li><a href="/sports/wvball/2017-18/teams"  aria-label="Teams: Women's Sports: Volleyball: Stats">Stats</a></li>
  
  


</ul>

 

 
      </div>
    </li>
  
  


</ul>

 

 
      </div>
    </li>
  
  


</ul>

 

 
            
    		    				
      </div>
    </li>
          
           
    <li class="nav nav2 has-submenu" data-follow-link="false">
      <a href="/navbar-information" class="nav-link" >Inside Athletics</a>
      <div id="submenu2" class="submenu level1 clearfix">

                                    




<ul class="clearfix">
    	
      <li><a href="http://www.giving.guilford.edu/athletics"  target="_blank"  aria-label="Inside Athletics: Give to Guilford Athletics">Give to Guilford Athletics</a></li>
  
  
    	
      <li><a href="/information/Mission"  aria-label="Inside Athletics: Mission Statement">Mission Statement</a></li>
  
  
    	
      <li><a href="/composite"  aria-label="Inside Athletics: Composite Schedule">Composite Schedule</a></li>
  
  
    	
      <li><a href="/information/directory/index"  aria-label="Inside Athletics: Staff Directory">Staff Directory</a></li>
  
  
    	
      <li><a href="/information/training/index"  aria-label="Inside Athletics: Athletic Training">Athletic Training</a></li>
  
  
    	
      <li><a href="http://www.bkstr.com/webapp/wcs/stores/servlet/StoreCatalogDisplay?catalogId=10001&langId=-1&demoKey=d&storeId=10467"  target="_blank"  aria-label="Inside Athletics: Bookstore">Bookstore</a></li>
  
  
    	
      <li><a href="/information/news/index"  aria-label="Inside Athletics: Quakers in the News">Quakers in the News</a></li>
  
  
    	
      <li><a href="/information/questionnaires/index"  aria-label="Inside Athletics: Recruiting Questionnaires">Recruiting Questionnaires</a></li>
  
  
    	
      <li><a href="/information/sportsinfo"  aria-label="Inside Athletics: Sports Information">Sports Information</a></li>
  
  
    	
      <li><a href="/aotw/index"  aria-label="Inside Athletics: Where Are They Now?">Where Are They Now?</a></li>
  
  


</ul>

 

 
            
    		    				
      </div>
    </li>
          
           
    <li class="nav nav3 has-submenu" data-follow-link="false">
      <a href="/navbar-facilities" class="nav-link" >Facilities</a>
      <div id="submenu3" class="submenu level1 clearfix">

                                    




<ul class="clearfix">
    	
      <li><a href="/facilities/Athletic_Training_Room"  aria-label="Facilities: Athletic Training">Athletic Training</a></li>
  
  
    	
      <li><a href="/facilities/baseball"  aria-label="Facilities: Baseball">Baseball</a></li>
  
  
    	
      <li><a href="/facilities/basketball"  aria-label="Facilities: Basketball">Basketball</a></li>
  
  
    	
      <li><a href="/facilities/xc"  aria-label="Facilities: Cross Country">Cross Country</a></li>
  
  
    	
      <li><a href="/facilities/football"  aria-label="Facilities: Football">Football</a></li>
  
  
    	
      <li><a href="/facilities/golf"  aria-label="Facilities: Golf">Golf</a></li>
  
  
    	
      <li><a href="/facilities/lacrosse"  aria-label="Facilities: Lacrosse">Lacrosse</a></li>
  
  
    	
      <li><a href="/facilities/soccer"  aria-label="Facilities: Soccer">Soccer</a></li>
  
  
    	
      <li><a href="/facilities/softball"  aria-label="Facilities: Softball">Softball</a></li>
  
  
    	
      <li><a href="/facilities/swim"  aria-label="Facilities: Swimming">Swimming</a></li>
  
      </ul><ul class="clearfix">
  
    	
      <li><a href="/facilities/tennis"  aria-label="Facilities: Tennis">Tennis</a></li>
  
  
    	
      <li><a href="/facilities/track"  aria-label="Facilities: Track and Field">Track and Field</a></li>
  
  
    	
      <li><a href="/facilities/Volleyball"  aria-label="Facilities: Volleyball">Volleyball</a></li>
  
  
    	
      <li><a href="/facilities/batting_center"  aria-label="Facilities: Batting Center">Batting Center</a></li>
  
  
    	
      <li><a href="/facilities/field_house"  aria-label="Facilities: Field House">Field House</a></li>
  
  


</ul>

 

 
            
    		    				
      </div>
    </li>
          
           
    <li class="nav nav4 has-submenu" data-follow-link="false">
      <a href="/navbar-history" class="nav-link" >History</a>
      <div id="submenu4" class="submenu level1 clearfix">

                                    




<ul class="clearfix">
    	
      <li><a href="/history/AllAmericans"  aria-label="History: All-Americans">All-Americans</a></li>
  
  
    	
      <li><a href="/history/dept"  aria-label="History: Athletic Department Awards">Athletic Department Awards</a></li>
  
  
    	
      <li><a href="/history/hof"  aria-label="History: Hall of Fame">Hall of Fame</a></li>
  
  
    	
      <li><a href="/history/sportaward"  aria-label="History: Individual Sport Awards">Individual Sport Awards</a></li>
  
  
    	
      <li><a href="/history/champion"  aria-label="History: National Championships">National Championships</a></li>
  
  


</ul>

 

 
            
    		    				
      </div>
    </li>
          
           
    <li class="nav nav5 has-submenu" data-follow-link="false">
      <a href="/navbar-camps" class="nav-link" >Camps &amp; Clinics</a>
      <div id="submenu5" class="submenu level1 clearfix">

                                    




<ul class="clearfix">
    	
      <li><a href="http://www.guilfordbaseballcamps.com"  target="_blank"  aria-label="Camps &amp; Clinics: Baseball">Baseball</a></li>
  
  
    	
      <li><a href="https://registrationelite.com/GuilfordMensBasketball/"  target="_blank"  aria-label="Camps &amp; Clinics: Men's Basketball">Men's Basketball</a></li>
  
  
    	
      <li><a href="http://www.guilfordwbbcamps.com/"  target="_blank"  aria-label="Camps &amp; Clinics: Women's Basketball">Women's Basketball</a></li>
  
  
    	
      <li><a href="/sports/fball/FBCampsIndex"  aria-label="Camps &amp; Clinics: Football">Football</a></li>
  
  
    	
      <li><a href="/sports/mlax/specialEvents/MLX_Fall_Challenge_2017.pdf"  aria-label="Camps &amp; Clinics: Men's Lacrosse">Men's Lacrosse</a></li>
  
  
    	
      <li><a href="/sports/wlax/2016-17/files/December_4_2016_WLX_Clinic.pdf"  aria-label="Camps &amp; Clinics: Women's Lacrosse">Women's Lacrosse</a></li>
  
  
    	
      <li><a href="/sports/sball/specialEvents/Winter_Clinic_2018.pdf"  aria-label="Camps &amp; Clinics: Softball">Softball</a></li>
  
  
    	
      <li><a href="/sports/msoc/MSCCampsIndex"  aria-label="Camps &amp; Clinics: Men's Soccer">Men's Soccer</a></li>
  
  
    	
      <li><a href="http://www.guilfordsoccercampsandclinics.com/index.cfm"  target="_blank"  aria-label="Camps &amp; Clinics: Women's Soccer">Women's Soccer</a></li>
  
  
    	
      <li><a href="/sports/wvball/VBCampsIndex"  aria-label="Camps &amp; Clinics: Volleyball">Volleyball</a></li>
  
  


</ul>

 

 
            
    		    				
      </div>
    </li>
          
           
    <li class="nav nav6 has-submenu" data-follow-link="false">
      <a href="/navbar-giving" class="nav-link" >Give to Athletics</a>
      <div id="submenu6" class="submenu level1 clearfix">

                                    




<ul class="clearfix">
    	
      <li><a href="http://www.giving.guilford.edu/athletics"  target="_blank"  aria-label="Give to Athletics: Athletics">Athletics</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/baseball"  target="_blank"  aria-label="Give to Athletics: Baseball">Baseball</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/mensbasketball"  target="_blank"  aria-label="Give to Athletics: Men's Basketball">Men's Basketball</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/womensbasketball"  target="_blank"  aria-label="Give to Athletics: Women's Basketball">Women's Basketball</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/menscrosscountry"  target="_blank"  aria-label="Give to Athletics: Men's Cross Country">Men's Cross Country</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/womenscrosscountry"  target="_blank"  aria-label="Give to Athletics: Women's Cross Country">Women's Cross Country</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/football"  target="_blank"  aria-label="Give to Athletics: Football">Football</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/golf"  target="_blank"  aria-label="Give to Athletics: Men's Golf">Men's Golf</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/menslacrosse"  target="_blank"  aria-label="Give to Athletics: Men's Lacrosse">Men's Lacrosse</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/womenslacrosse"  target="_blank"  aria-label="Give to Athletics: Women's Lacrosse">Women's Lacrosse</a></li>
  
      </ul><ul class="clearfix">
  
    	
      <li><a href="http://www.giving.guilford.edu/menssoccer"  target="_blank"  aria-label="Give to Athletics: Men's Soccer">Men's Soccer</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/womenssoccer"  target="_blank"  aria-label="Give to Athletics: Women's Soccer">Women's Soccer</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/volleyball"  target="_blank"  aria-label="Give to Athletics: Volleyball">Volleyball</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/softball"  target="_blank"  aria-label="Give to Athletics: Softball">Softball</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/swimming"  target="_blank"  aria-label="Give to Athletics: Women's Swimming">Women's Swimming</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/menstennis"  target="_blank"  aria-label="Give to Athletics: Men's Tennis">Men's Tennis</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/womenstennis"  target="_blank"  aria-label="Give to Athletics: Women's Tennis">Women's Tennis</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/menstrack"  target="_blank"  aria-label="Give to Athletics: Men's Track &amp; Field">Men's Track &amp; Field</a></li>
  
  
    	
      <li><a href="http://www.giving.guilford.edu/womenstrack"  target="_blank"  aria-label="Give to Athletics: Women's Track &amp; Field">Women's Track &amp; Field</a></li>
  
  


</ul>

 

 
            
    		    				
      </div>
    </li>
                <li class="nav nav7"><a href="/landing/index"  class="nav-link">Home</a></li>
                <li class="nav nav8"><a href="http://www.guilford.edu/"  target="_blank"  class="nav-link">Guilford.EDU</a></li>
      	
  </ul>
<div class="none close">Close</div></nav>

 


<div id="wrapper">



<div id="secondary-nav" class="secondary-nav clearfix">

  <h1>Men's Lacrosse<span class="icon-menu"></span></h1>

<ul class="clearfix">

<li><a href="/sports/mlax/2017-18/roster" >Team</a></li>




<li><a href="/sports/mlax/2017-18/schedule" >Schedule</a></li>




<li><a href="/sports/mlax/2017-18/news" >News</a></li>




<li><a href="/sports/mlax/2017-18/teams" >Stats</a></li>




<li><a href="/sports/mlax/coaches/index" >Staff</a></li>




<li><a href="/sports/mlax/archive" >History</a></li>




<li><a href="/sports/mlax/Records/index" >Records</a></li>




<li><a href="http://www.giving.guilford.edu/menslacrosse"  target="_blank" >Give to Men's Lacrosse</a></li>




<li><a href="/sports/mlax/specialEvents/MLX_Fall_Challenge_2017.pdf" >Camp</a></li>

  <li class="more"><a href="#">More+</a>
  <ul class="dropdown">



<li><a href="/sports/mlax/Alumni_Form" >Alumni</a></li>


 </ul></li>

</ul>

</div>


<script>
$(function() {
  $('.secondary-nav > h1').click(function() {
    $(this).toggleClass('active').next('ul').toggleClass('active');
  });
});
</script>

 

<div id="body-container" class="body-container clearfix">










<div class="navbar-buttons social-buttons clearfix">
<ul class="clearfix">
    <li class="nav nav1">
  <a class="nav-link" href="https://www.facebook.com/goquakers" target="_blank">
    <span>Facebook</span>  </a>
  </li>
      <li class="nav nav2">
  <a class="nav-link" href="https://twitter.com/goquakers" target="_blank">
    <span>Twitter</span>  </a>
  </li>
      <li class="nav nav3">
  <a class="nav-link" href="https://instagram.com/goquakers/" target="_blank">
    <span>Instagram</span>  </a>
  </li>
      <li class="nav nav4">
  <a class="nav-link" href="https://www.youtube.com/user/GuilfordAthletics" target="_blank">
    <span>Youtube</span>  </a>
  </li>
      <li class="nav nav5">
  <a class="nav-link" href="http://www.guilfordquakers.com/rss/index" >
    <span>RSS</span>  </a>
  </li>
  </ul>

</div>

<div id="mainbody" class="mainbody clearfix">

  
<div class="infinite-articles" data-module="infinite-articles">
        <div class="articles">
            	

<div class="rich-v2 modern no-sidebar clearfix" data-module="article-rich" data-title="Quaker Men's Lacrosse Posted 9-8 Season" data-url="/sports/mlax/2017-18/releases/20180702q90rsp">
  

	
      <h1 class="article-title">Quaker Men's Lacrosse Posted 9-8 Season</h1>
  

	
	  
        
    <div class="article-image">
      <div class="image">

                    <img src="/sports/mlax/2016-17/photos/0009/Styles-_Parker_-18_thumb.jpg" alt="Parker Styles '18" />
          
          
                  <div class="thumb-caption">Parker Styles '18</div>
          
              </div>
    </div>
  

<div class="article-body clearfix">
	
			
		

<div class="article-text">
    
    <div class="img-video-ad"></div>

<div class="article-date">
    <div class="date">Jul 02, 2018</div>
  
  	<div class="like-buttons" data-module="share-buttons">
          <div class="fb-like-btn"><a class="addthis_button_facebook_like" fb:like:layout="button_count"></a></div>
              <div class="tweet-btn"><a class="addthis_button_tweet"></a></div>
        </div>
  </div>

	
<p>The Guilford College men's lacrosse team finished with a 9-8 record for the 2018 season.</p>
<p>The Quakers got off to a 1-2 start and then went on a fantastic winning streak. GC won seven straight games--the longest since 1986--culminating with a 10-4 home victory over Old Dominion Athletic Conference (ODAC) rival Shenandoah. Another early-season highlight was a 14-9 result at Virginia Wesleyan on March 10.</p>
<p>At that time Guilford had an 8-2 record, including 2-0 in the ODAC. Bridgewater then bested the Quakers, 14-9. GC then struggled through the rest of the schedule and concluded with a 3-6 mark in conference play.</p>
<p>The final win for GC was a 22-6 trouncing of visiting Randolph College on April 14. The Quakers dished 16 assists in the contest, matching a Guilford single-game record.</p>
<p>The Quakers had two student-athletes, seniors <a href="/sports/mlax/2017-18/bios/bland_aswan_taj7">Aswan Bland</a> and <a href="/sports/mlax/2017-18/bios/forrestal_will_l11s">Will Forrestal</a>, earn All-ODAC honors. Both were tabbed to the second team.</p>
<p>Bland scored a goal in all 17 Quakers' contests and led the team with a career-high 40 points. Bland also paced Guilford with a personal-best 40 goals, sixth-best among conference leaders. He also contributed 37 ground balls and 10 caused turnovers. Bland, who graduated with a business administration degree, contributed 77 points in his two years with the Quakers. He scored 65 goals and 12 assists in 33 career appearances.</p>
<p>Forrestal, a defenseman, became Guilford's sixth two-time All-ODAC men's lacrosse student-athlete. He contributed three goals and one assist but made his mark as Guilford's' leader with 28 caused turnovers, the ODAC's second-highest figure. Forrestal also paced the Quakers with a career-high 59 ground balls. Forrestal won Guilford's 2018 English Athletic Leadership Award, the school's highest athletics honor, as well as the 2018 George Wynne Most Improved Athlete honor. Forrestal leaves second in school history with 79 career caused turnovers. He also had 19 points (10g, 9a) and 123 ground balls in 65 appearances.&nbsp;</p>
<p>In addition to a winning record, Guilford had many other notable team and individual accomplishments during the year. The Quakers allowed just 9.77 goals-per-game, which is the second-best in program history. Goalkeeper <a href="/sports/mlax/2017-18/bios/styles_parker_vne0">Parker Styles</a> exits Guilford with the best goals-against average mark (9.48) and the most minutes-played (2873)&nbsp;in team history. He started all 17 games for GC.</p>
<p>Zack Berkowitz was second on the team in points with 38. The junior tallied 24 goals and passed 14 assists. <a href="/sports/mlax/2017-18/bios/sweeney_brennan_e4t1">Brennan Sweeney</a> netted 10 goals and delivered a team-best 22 helpers for the Quakers. <a href="/sports/mlax/2017-18/bios/spaulding_derek_vmx6">Derek Spaulding</a>, a senior, was second on the club with 27 goals.&nbsp;</p>
<p>Following the season, Tom Carmean resigned his position as Guilford College's head coach. Carmean closed his Guilford career with a 67-61 (.523 winning percentage) mark. He surpassed Guilford Athletics Hall of Famer Geoff Miller as the winningest coach in program history with a 2018 win over Cazenovia College.&nbsp;</p>
<p>Guilford assistant Mark Crisco was named the Quakers' interim head coach. Guilford could return as many as 29 returnees for the 2019 campaign.</p>
<p>&nbsp;</p>



	<div class="article-footer clearfix"></div>

  
  

<div class="share-buttons clearfix" data-module="share-buttons">

	<div class="share-btn facebook">
		<a class="addthis_button_facebook" role="button" aria-label="Share this page on Facebook">
			<span class="gicon-facebook"></span><span class="text">Facebook</span>
		</a>
	</div>

	<div class="share-btn twitter">
		<a class="addthis_button_twitter" role="button" aria-label="Share this page on Twitter">
			<span class="gicon-twitter"></span><span class="text">Twitter</span>
		</a>
	</div>

	<div class="share-btn gplus">
		<a class="addthis_button_google_plusone_share" role="button" aria-label="Share this page on Google+">
			<span class="gicon-gplus"></span><span class="text">Google+</span>
		</a>
	</div>

	<div class="share-btn email">
		<a class="addthis_button_email" role="button" aria-label="Share this page via email">
			<span class="gicon-mail"></span><span class="text">Email</span>
		</a>
	</div>

	<div class="share-btn print">
		<a href="http://www.guilfordquakers.com/sports/mlax/2017-18/releases/20180702q90rsp?dec=printer-decorator" target="_blank" title="Print" class="printer-friendly" role="button" aria-label="Print this page">
			<span class="gicon-print"></span><span class="text">Print</span>
		</a>
	</div>

	<div class="share-btn addthis">
		<a class="addthis_button_more" role="button" aria-label="More Sharing Services">
			<span class="gicon-addthis"></span><span class="text">Addthis</span>
		</a>
	</div>

</div>

</div>

  
</div> 




</div> 
        </div>
        
            <div class="rel-articles">
        <div class="container">
                    <div  class="preview active loaded" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0009/Styles-_Parker_-18_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Quaker Men's Lacrosse Posted 9-8 Season" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">July 2, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180702q90rsp" class="title">Quaker Men's Lacrosse Posted 9-8 Season</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0011/IMG_5389_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Tom Carmean Resigns Guilford Men's Lacrosse Post" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">June 1, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180516i5hd8t" class="title">Tom Carmean Resigns Guilford Men's Lacrosse Post</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0010/All-ODAC-Men-s-lax-slide.png?max_width=280&max_height=160&crop=true" alt="Guilford Pair Named to All-ODAC Men's Lacrosse Team" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">May 10, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180510tuve7j" class="title">Guilford Pair Named to All-ODAC Men's Lacrosse Team</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/images/setup/thumbnail_default.jpg?max_width=280&max_height=160&crop=true" alt="Quakers' Quartet Named Arthur Ashe, Jr. Sports Scholars" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">May 4, 2018</span>
                    <a href="/general/2017-18/releases/20180504oxj4jd" class="title">Quakers' Quartet Named Arthur Ashe, Jr. Sports Scholars</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0010/Spaulding--Derek--40_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Randolph-Macon Claims 15-9 Men's Lacrosse Win at Guilford" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 28, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180428zmn85q" class="title">Randolph-Macon Claims 15-9 Men's Lacrosse Win at Guilford</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0010/Craig--Bryce--20.png?max_width=280&max_height=160&crop=true" alt="Nationally Ranked Washington and Lee Rallies Past Guilford in Men's Lacrosse, 13-8" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 25, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180425vibakc" class="title">Nationally Ranked Washington and Lee Rallies Past Guilford in Men's Lacrosse, 13-8</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/general/2017-18/photos/0005/Combined-Awards-Group.png?max_width=280&max_height=160&crop=true" alt="Top Student-Athletes Honored at 2018 Quakies Awards" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 22, 2018</span>
                    <a href="/general/2017-18/releases/20180424fa18z7" class="title">Top Student-Athletes Honored at 2018 Quakies Awards</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0008/IMG_7207_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Strong Second Half Helps Hampden-Sydney to Men's Lacrosse Win Over Guilford" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 21, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180421si4cwm" class="title">Strong Second Half Helps Hampden-Sydney to Men's Lacrosse Win Over Guilford</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0007/Celebrate_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Guilford Wears Out Nets in 22-6 ODAC Men's Lacrosse Win Over Randolph" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 14, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180414woa57v" class="title">Guilford Wears Out Nets in 22-6 ODAC Men's Lacrosse Win Over Randolph</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0005/IMG_1439_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Lynchburg Downs Visiting Guilford for ODAC Men's Lacrosse Win" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 7, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180407x2j986" class="title">Lynchburg Downs Visiting Guilford for ODAC Men's Lacrosse Win</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0014/IMG_2117_thumb_thumb.jpg?max_width=280&max_height=160&crop=true" alt="#16 Roanoke Holds Off Guilford for 9-5 ODAC Men's Lacrosse Win" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 4, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180404y1x0b1" class="title">#16 Roanoke Holds Off Guilford for 9-5 ODAC Men's Lacrosse Win</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0006/Kawugule-Slide_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Guilford Rookie to Play in 2018 World Lacrosse Championships" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">April 2, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180402ovuq20" class="title">Guilford Rookie to Play in 2018 World Lacrosse Championships</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0004/IMG_1004_-1-_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Bridgewater Ends Guilford Men's Lacrosse Winning Streak at Seven" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 31, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180331xp0mo8" class="title">Bridgewater Ends Guilford Men's Lacrosse Winning Streak at Seven</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0004/IMG_0637_-1-_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Quakers Notch Seventh Straight Men's Lacrosse Win" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 24, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180324v9hb8e" class="title">Quakers Notch Seventh Straight Men's Lacrosse Win</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0004/IMG_0933_-1-_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Quakers Push Men's Lacrosse Win Streak to Six With Rout of Ferrum" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 17, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180317rcygxb" class="title">Quakers Push Men's Lacrosse Win Streak to Six With Rout of Ferrum</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0011/IMG_5389_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Carmean Sets Guilford Men's Lacrosse Coaching Wins Mark In Win Over Cazenovia" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 14, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180314s74o0n" class="title">Carmean Sets Guilford Men's Lacrosse Coaching Wins Mark In Win Over Cazenovia</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0002/IMG_3593_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Guilford Wins at Virginia Wesleyan, 14-9, in ODAC Men's Lacrosse Opener" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 10, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180310xank8p" class="title">Guilford Wins at Virginia Wesleyan, 14-9, in ODAC Men's Lacrosse Opener</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0003/Bland--Aswan--19-Westminster_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Guilford Pours in Season-High 21 Goals in Men's Lacrosse Rout of Pfeiffer" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 7, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180307xa0mvs" class="title">Guilford Pours in Season-High 21 Goals in Men's Lacrosse Rout of Pfeiffer</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0003/Spaulding--Bland-celebrate.png?max_width=280&max_height=160&crop=true" alt="Guilford Rolls to 15-6 Men's Lacrosse Win Over Westminster" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">March 4, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180304pf9i6t" class="title">Guilford Rolls to 15-6 Men's Lacrosse Win Over Westminster</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2017-18/photos/0002/IMG_3518_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Strong Defense, Balanced Offense Lifts Guilford to 8-4 Men's Lacrosse Win at Methodist" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">February 28, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180228ws28yu" class="title">Strong Defense, Balanced Offense Lifts Guilford to 8-4 Men's Lacrosse Win at Methodist</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0009/Styles-_Parker_-18_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Southern Virginia Scores 13-12 Men's Lacrosse Win at Guilford" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">February 24, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180224v32emi" class="title">Southern Virginia Scores 13-12 Men's Lacrosse Win at Guilford</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0011/Bland--Aswan--18_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Balanced Scoring Carries Guilford to 18-8 Men's Lacrosse Win at Greensboro" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">February 21, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180221wgpb8l" class="title">Balanced Scoring Carries Guilford to 18-8 Men's Lacrosse Win at Greensboro</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0014/IMG_2117_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Quakers' Rally Falls Short in Season-Opening Men's Lacrosse Match" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">February 17, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180217yf6nte" class="title">Quakers' Rally Falls Short in Season-Opening Men's Lacrosse Match</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/history/HoFImages/Miller--Geoff_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Former Men's Lacrosse Coach Named to North Carolina Lacrosse Hall of Fame" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">February 13, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180213hdvvb3" class="title">Former Men's Lacrosse Coach Named to North Carolina Lacrosse Hall of Fame</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/sports/mlax/2016-17/photos/0005/Forrestal-_Will_-18_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Guilford Picked Sixth in ODAC Mens Lacrosse Poll" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">February 2, 2018</span>
                    <a href="/sports/mlax/2017-18/releases/20180202hideko" class="title">Guilford Picked Sixth in ODAC Mens Lacrosse Poll</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/images/setup/thumbnail_default.jpg?max_width=280&max_height=160&crop=true" alt="182 Named to Fall 2017 Student-Athlete Honor Roll" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">January 3, 2018</span>
                    <a href="/general/2017-18/releases/20180103ghxp78" class="title">182 Named to Fall 2017 Student-Athlete Honor Roll</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/general/2017-18/photos/0002/Guilford-Lacrosse-at-Autism_thumb.jpg?max_width=280&max_height=160&crop=true" alt="Guilford Lacrosse Teams Break Fundraising Goals in Autism Run" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">October 9, 2017</span>
                    <a href="/general/2017-18/releases/20171009nd2hmw" class="title">Guilford Lacrosse Teams Break Fundraising Goals in Autism Run</a>
                </div>
            </div>
                    <div  class="preview" >
                <div class="thumb">
                                    <img data-src="/splash/CAN_DO_Slide.png?max_width=280&max_height=160&crop=true" alt="Guilford Athletics Participates in CAN DO Food Drive" class="lazyload" />
                                </div>
                <div class="info">
                    <span class="date">October 1, 2017</span>
                    <a href="/general/2017-18/releases/20171003x2yjlu" class="title">Guilford Athletics Participates in CAN DO Food Drive</a>
                </div>
            </div>
                </div>
    </div>

    </div>



<div class="gpt-adhesion-placeholder">
    <div id="gpt-ad-adhesion">
    <script type="text/javascript">
        googletag.cmd.push(function() { googletag.display('gpt-ad-adhesion'); });
    </script>
    </div>
</div>
<script>
(function($) {
    $(window).on('endscroll', function() {
        if ($(window).scrollTop() >= ($(window).height() / 3)) {
            $('.gpt-adhesion-placeholder').addClass('collapse');
        } else {
            $('.gpt-adhesion-placeholder').removeClass('collapse');
        }
    });
})(jQuery);
</script>

</div> </div> 
<footer id="site-footer" class="site-footer clearfix">
 









<div class="navbar-buttons footer-logos clearfix">
<ul class="clearfix">
    <li class="nav nav1">
  <a class="nav-link" href="http://www.odaconline.com" target="_blank">
            <img src="https://cdn.prestosports.com/action/cdn/r2eemtzx08n04thi/images/setup/2014/footer_logo_01.png?max_width=" alt="" />   
          </a>
  </li>
      <li class="nav nav2">
  <a class="nav-link" href="http://www.d3sports.com" target="_blank">
            <img src="https://cdn.prestosports.com/action/cdn/r2eemtzx08n04thi/images/setup/2014/footer_logo_02.png?max_width=" alt="" />   
          </a>
  </li>
      <li class="nav nav3">
  <a class="nav-link" href="http://www.ncaa.org/d3" target="_blank">
            <img src="https://cdn.prestosports.com/action/cdn/r2eemtzx08n04thi/images/setup/2014/footer_logo_03.png?max_width=" alt="" />   
          </a>
  </li>
      <li class="nav nav4">
  <a class="nav-link" href="http://www.ncaa.org" target="_blank">
            <img src="https://cdn.prestosports.com/action/cdn/r2eemtzx08n04thi/images/setup/2014/footer_logo_04.png?max_width=" alt="" />   
          </a>
  </li>
      <li class="nav nav5">
  <a class="nav-link" href="http://www.prestosports.com" target="_blank">
            <img src="https://cdn.prestosports.com/action/cdn/r2eemtzx08n04thi/images/setup/2014/footer_logo_05.png?max_width=" alt="" />   
          </a>
  </li>
  </ul>

</div>


<div class="footer-title clearfix">
<p><span>Guilford College, 5800 West Friendly Ave., Greensboro, NC 27410</span></p>
</div>




<div class="footer-address clearfix">
<p><span>&copy 2018 Guilford College Athletics.</span>
<span>All Rights Reserved. Unauthorized use of logos, photos, graphics</span>
<span>and story copy is prohibited without prior written permission</span>
<span>from the Guilford College Sports Information Office</span></p>
</div>



</footer>

</div> </div> 


  

<div id="page-background">
</div>

<script>
$(window).load(function() {
  var src = "/images/setup/2014/page_bg.jpg";
  var b = new Image();
  $(b).load(function() {
    $(this).appendTo('#page-background');
  }).attr('src', src);
});
</script>

 

<script src="https://cdn.prestosports.com/action/cdn/info/jquery.lazyload.min.js"></script>
<script>
$(function() {
  $('.lazy').lazyload();
});
</script>

<script type="text/javascript">var _qevents = _qevents || [];(function() {var elem = document.createElement('script');elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge")+ ".quantserve.com/quant.js";elem.async = true;elem.type = "text/javascript";var scpt = document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem, scpt);})();</script><script type="text/javascript">_qevents.push( { qacct:"p-c1MZx5LfVe-Xw"} );</script><noscript><div style="display: none;"><img src="http://pixel.quantserve.com/pixel/p-c1MZx5LfVe-Xw" height="1" width="1" alt=""/></div></noscript><script>var _comscore = _comscore || [];_comscore.push({ c1: "2", c2: "19291688" });(function() {var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s, el);})();</script><noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=19291688&cv=2.0&cj=1" alt="" /></noscript>
<!-- dropoff-scripts -->


<script type="text/javascript" src="https://cdn.prestosports.com/action/cdn/info/videojs/js/video.min.js"></script>

<script type="text/javascript" src="https://cdn.prestosports.com/action/cdn/info/videojs/js/videojs-flash.min.js"></script>


















<script type="text/javascript" src="https://cdn.prestosports.com/action/cdn/info/cookie-handler.js"></script>

<script type="text/javascript">
$(function() {
	if (readCookie('adminuser')) {
		$('body').append('<span id="edit-page-btn" style="display: block; padding: 10px; z-index: 9999; background: #000; color: #fff; font-size: 12px; position: fixed; right: 0; top: 0; cursor: default">Edit Page</span>');
		$('#edit-page-btn').click(function() {
			url = document.location.protocol + '//' + document.location.hostname
			if (document.location.port) url += ':' + document.location.port;
			url += '/admin/content/wiki/g2g';
			url += document.location.pathname;
			window.location = url;
		});
	}
});
</script>

<script type="text/javascript">
$(function() {
  if (window.self == window.top) {
    return;
  }
  var heroic = document.referrer.indexOf("herosports.com/");
  if (heroic > -1) {
    alert("We do not allow HERO Sports to frame our site.");
    window.top.location = window.location;
  }
});
</script>

<script data-main="/info/main.js" src="/info/vendor/require.js"></script>

<!-- rum footer -->

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"errorBeacon":"bam.nr-data.net","licenseKey":"a8324e80d1","agent":"","beacon":"bam.nr-data.net","applicationTime":260,"applicationID":"1004718","transactionName":"MgcAZENYXhJYVkFdXQtNJFldTVUTFnFaWVMMDEJeUFRVQV9cWUBXFw==","queueTime":0}</script>



            <div class="img-video-ad">
            <script>!function(e,t,a,n,g){e[n]=e[n]||[],e[n].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var m=t.getElementsByTagName(a)[0],r=t.createElement(a);r.async=!0,r.src="https://www.googletagmanager.com/gtm.js?id=GTM-PL4PD49",m.parentNode.insertBefore(r,m)}(window.parent,window.parent.document,"script","dataLayer");</script>
            <script>var iframe=window.parent.document.createElement("iframe");iframe.src="https://www.googletagmanager.com/ns.html?id=GTM-PL4PD49";iframe.height="0";iframe.width="0";iframe.style="display:none;visibility:hidden";window.parent.document.body.appendChild(iframe);</script>
            <script>window.parent['$$mm-analytics'] = window.parent['$$mm-analytics'] || {};if (typeof window.parent['$$mm-analytics'].firstEmbed === 'undefined') {window.parent['$$mm-analytics'].firstEmbed = Date.now();}</script>
            <script async type='text/javascript' src="https://bucket1.mm-syringe.com/prod/configs/b79a504e-02de-4dfe-9a01-8f57ac48ce0a.js"></script>
            <script async type='text/javascript' src="https://bucket1.mm-syringe.com/prod/injector/injector.1.1.js"></script>  
        </div>
    

</body>
</html>

 